Power Wagon Advertiser Forums Vintage Powerwagons

Go Back   Power Wagon Advertiser Forums > FORUM USERS, FEATURES & BENEFITS > Help forum

Notices

Help forum A place for questions on how to use the forums.

Reply
 
Thread Tools Display Modes
Old 05-31-2015, 04:17 PM   #1
The Other Ross
Subscriber
 
The Other Ross's Avatar
 
Join Date: Oct 2004
Posts: 386
tests

Test
Attached Images
File Type: jpg WP_20150520_002.jpg (73.1 KB, 51 views)
__________________
1964 w300 440 9' utility bed
1972 w200 440-III,445 4 speed,Dana 60's w L/S
1975 d500 flatbed dump
1990 D350 Cummins 5 speed one ton flatbed(ugly maybe donor for ???)
1998 3500 12 valve Cummins Quadcab 4x4 Dually
Various and sundry IH farm and construction equipment
Not enough firearms
The Other Ross is online now   Reply With Quote
Old 08-06-2017, 06:15 PM   #2
The Other Ross
Subscriber
 
The Other Ross's Avatar
 
Join Date: Oct 2004
Posts: 386
Quote:
Originally Posted by The Other Ross View Post
Test
I seem to have forgotten how to upload pics. I apparently used to know.
__________________
1964 w300 440 9' utility bed
1972 w200 440-III,445 4 speed,Dana 60's w L/S
1975 d500 flatbed dump
1990 D350 Cummins 5 speed one ton flatbed(ugly maybe donor for ???)
1998 3500 12 valve Cummins Quadcab 4x4 Dually
Various and sundry IH farm and construction equipment
Not enough firearms
The Other Ross is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:36 PM.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright ©2002 - 2017, Power Wagon Advertiser. All rights reserved.